読者です 読者をやめる 読者になる 読者になる

ぱっけーじと名前空間とモジュール

Uva Advent_Calendar_2015

Uva Advent Calendar 2015 5 日目。

昨日はりひにーさんで ゆーえすあーる でした。

ʕ•͡ω•ʔ Java だと package にクラスをまとめるけど、package ってなんか違和感あるんだよな

ʕ•͡ω•ʔ Java でいう packagenamespace にしたい(C# or C++ 脳)

ʕ•͡ω•ʔ namespace をまとめたものを module と呼びたいし、module をまとめたものを package と呼びたい

ʕ•͡ω•ʔ イメージには namespace 単位とか module 単位とかでも package 単位でも取り込めるし、逆にイメージから切り離せたりしたい